Telemetry doesn't recognized by Windows PC's ports


I had both 915mhz and 433mhz telemetry modules but I couldn’t get them to work properly. The 915mhz telemetry module doesn’t even paired right now. The 433mhz version is paired but when I plug the groud module to my windows 10 pc, it doesn’t even recognized by Windows. So, I really am tired. Can somebody please help me? At this point I’m at the final stages of the course and all I want is to make this thing work so I can develop further.



When you say not pairing do you mean that with the drone powered and the telemetry usb plugged into your laptop, the light is not solid green?

In device manager, is the USB device being showin in the Ports section? If so, right click and check for driver updates on it. I’m using the 915MHz module and didn’t have problem with it. If its not showing up in the device manager, check your computer’s USB port.

If you try to connect in mission planner, what do you see?




The 915mhz telemetry module for ground and air have this blinking green light, yes. But I’m going to return them tomorrow. The strange part is, when I plug in the 433mhz telemetry module, I expect to hear this Windows sound for port usage right? So, I don’t hear anything or see it in the device manager. So, there is no COM3 or anything like that. And I can’t even see a driver being installed since the port looks like isn’t being used. I’ll buy new ones tomorrow and return the old ones.

By the way, I connected to my drone via UDP but as far as I understand I can’t get firmware information or parameters into APM Planner or Mission Planer via UDP. Is that correct? If so, how can I go around this? I’d like to have an unlimited range, and I think it is possible with 4G. So do you have any documentation I can read or a video tutorial on this? Because calibration requires telemetry but do I really need it?


Hi there onurbaskin!

You should be able to get firmware and parameter information into MissionPlanner via only UDP, but it does have more limited range compared to the 915 or 433 telemetry modules.

A few students have gone through the issue of the telemetry modules not pairing (blinking green), and solved their issues as you have with a return and replace. As for your 433 module not even registering on the device manager- this is strange. Sometimes devices will appear in an ‘Other’ type section in the Device Manager, I wonder if you see any devices under this section in Device Manager? If you do, it will be possible to look at the driver being used and it could potentially be fixed.

One thing I would try as well is to plug the 433 module into a different windows computer to see if the issue is isolated to that particular computer. It should also be noted that not all telemetry modules found on amazon provide a great experience, and many will have drivers that don’t really work out of the box.

The only telemetry modules I can guarantee (because I’ve tested it) are the readytosky modules here, at least when they are properly pairing. Could you point me to the product link for the 433 modules you’re trying?

Also, I don’t have direct experience with 4G equipped drones, but many others have accomplished this and provide some video for their experience on YouTube. I plan to at some point dive into this subject for DroneDojo’ers and then provide step-by-step guides, but that may not be for a bit :slight_smile:


It does not appear. :confused:

I have tried on a freshly installed Windows 10 PC but it does not appear. So I’m sure it is not a PC related issue.

I have tried this one. But I’m going to return them first thing on Monday.

When I return them and get the new ones working properly I’ll update this topic. And I’m waiting for your new videos. They are amazing. And one more thing, it would be really nice if you cover every part of a drone. I mean an entire video on ESC’s, or something like that. It just my honest opinion. Can we find a video about that on YouTube? Yes. But do I wanna hear it from you? Sure as hell I wanna :smiley:


Ok cool! Sorry they weren’t pairing for you. It seems ~5-10% of those modules haven’t been pairing lately- it may be time to find a new telemetry manufacturer that is more dependable!

Thanks for the compliment @onurbaskin :grinning: you guys are my fuel for sure so I appreciate that!

So you’re thinking like maybe a 20-30 minute deep dive into the various drone parts? Like for ESCs maybe the different firmware versions (SimonK, BLHeli, oneshot etc), how they work and not just a high level overview? Honestly I think that would be a good idea!


Yeah. A deep dive would be so helpful. You can talk about how the electronics work and why a particular PCB has built the way it is… I mean, I love software development, that’s my job, but there is something mysterious about electronics. Plus, how you teach is something else. You can make another course out of them. Thanks again for the great content and quick responses :smiley: I’ll let you know when the new telemetry modules come.


Haha agreed, the DIY drone culture does sort of ‘black box’ the magical low level electronics :joy: that really does sound like a good idea!

I look forward to your next message telling us your telemetry modules were paired this time! If they aren’t… I may have to personally send you mine cause that’d be ridiculous.



Does anybody know, out of the box 915 MHz telemetry module’s parameters? :smiley: because my newest 433mhz telemetry module is not working. Again… :smiley: (f*#k 433 MHz, long live 915 MHz). So, yeah. I need the 915 MHz telemetry module’s parameter since I don’t know why but the company who manufactured it has a USB port only for the ground module, not for the air oneeee :smiley: You guessed right. I need to reset the air module but hooww? :smiley:

By the way, I saw a video about shorting the wires that will eventually reset everything. Even though I can’t find the video again, I don’t want to short the wires. The last time I followed a tutorial liked that I changed my motherboard :DD so yeah help me out :smiley:


Hi there @onurbaskin

I’m thinking this is either a NETID issue or a firmware issue. My hunch is your problem could be solvable if you could find a way to plug in your UART telemetry module into your computer with a UART to USB device like this here.

Then you could configure the firmware with MP by selecting the right COM port, going to ‘Initial Setup < SiK Radio’, typing ‘Load Settings’ then ‘Upload Firmware (Local)’

You could then do this for the USB telemetry module too.

Funny thing, I accidentally broke my telemetry connection by uploading the local firmware to just one of my previously paired modules, and saw the dreaded blinking green lights.

Then I plugged the other telemetry device into the computer, uploaded the firmware on that device as well, and the coveted solid green lights appeared.


This is my exact problem with the 915 mhz telemetry module. Check this link and you’ll see there is only one USB connection. It is on ground control and I did the same mistake as you did. So, now I’m going to order this UART converter and update this thread. I guess in Turkey, nobody actually cares about drones and Amazon has problems with shipping, so I’ll find a similar converter.

Thanks again for your time. It means a lot.


No problem @onurbaskin

Ah I see. Sorry this has been such a hassle for you! Hoping that UART converter comes in quickly for ya.

In the meantime if you’re blocked by anything with your drone, you should be able to use a internet based UDP telemetry connection between MP and your drone if you’re itching to keep going!


Oh, I’ve tried that. It works fine and I managed to calibrate a few things but to “fetch” parameters it requires radio telemetry. By the way, the UART converter will come in a few hours so after I try it, I’ll update here again :smiley:


A quick update :smiley:

I’ve got the converter you mentioned but I was just looking for a similar converter on Turkish E-Commerce websites :smile: So, what you mentioned and what I found both are wrong. But I didn’t know this. I ordered anyway, and then I prepared the connections and soldered them but apparently, I ordered a converter for Arduino :grimacing:

It converts (I guess) with CH350 Chip, but later I realized that I needed what we installed before. Our telemetry modules are using a chip which it requires a driver called “CP210x USB to UART Bridge VCP Driver”… Have you noticed the CP210x… Yeah, I’ve got CH350, and apparently, it is popular among Arduino related hardware :smiley:

TLDR; I’ve got the right converter with the wrong chip/driver. I ordered a new one and I’m going to test it tomorrow morning.


I believe any device that could accept as input a UART signal and transmit that signal to USB (via some form of witchcraft) would work. It is my understanding that a CP210x, CH340, FT232 (what I referenced) would work, with one of the main difficulties being finding the right driver to make the hardware work automatically. But I could be wrong on this as I haven’t dove into this realm recently.

Glad to hear you have speedy eCom Turkish alternatives!


Hi again,

As you can see, I’ve got both of the devices recognized and visible on the device manager screen. The converter connected to “COM3” and it is my “FPV Radio Telemetry Air Module”. The COM4 is the ground control piece. This one is for 915MHz telemetry modules.

Quick summary: 2 weeks ago, I accidentally reset the Ground Module(COM4, in this screenshot), and that led to the unpairing of modules. Now, Air Module(COM3, in this screenshot) has the default settings and I can’t connect to it.

If you check the Mission Planner Screenshots, I cannot connect to the COM3 device, it fails.

When it fails, it shows this error.

The telemetry images for you to see the latest situation :smiley:

COM4 Port which is my ground module has the properties visible in this screenshot.

The 433MHz version next to 915MHz version.

So, can I say that my issue with the telemetry being not recognized by my PC is over and my current issue is I can’t make the Mission Planner to see the device or something?


this is so frustrating…I’ve been going through the same issues except, my telemetry worked only once ! before this green flashing nightmare.
I tried the local firmware upload from mission planner and still nothing. my computer cannot recognize the module anymore.
I downloaded the vcp and set up cp210x but nothing. how can we check if drivers are installed and working ?
although I remember that telemetry worked when I had the arducopter 3.6.10 which had other issues that were fixed by 3.6.11


Hi iyad,

You can see the installed drivers in the “add or remove programs” section in windows. Any recognized device also visible under “device manager”. Just don’t forget to choose “show hidden devices” under view.

I also saw the constant green light but in my case, I couldn’t make the connection with the Mission Planner. So, thanks to my genius instincts, I reset the ground module’s settings. That led to connection lost :smiley:

Further update for my case.

I finally said “enough” and went with UDP connection because no matter what I do, I can’t make the telemetry modules work. So, once I configure everything. I tested the radio controller. I increased the power. It didn’t take off.I realized, I mounted the propellers wrong. I fixed it. Then I crashed the drone because I have walls indoors rigghttt? :smiley:

I went outside. It flew up to 20 meters and then I wanted to land it. I had the same issue as it was in the videos. My channels needed to be reversed. As soon as I realized that I panicked and my drone crashed again :smiley:

The final test was to see if my radio controller has the proper channel settings. It was correct but I crashed again and broke my SD Card. Tomorrow I’m going to buy a new one. So, I need to calibre everything from scratch :smiley:

It is fun though. And Caleb if you are reading this, I’ll try to find a way to setup a proper 4G connection to these drones. If I can make it work or find a great documentation, I’ll send a link to you. Maybe, telemetry modules are just gateaway drug to buying DJI drones :smiley:


thanks for the update.
i connected each of them separately to mission planner and loaded the same firmware and saved the same options. i managed to get them both green solid when both connected to my PC. i dont know what that means since non of them are showing as siLab. but when i disconnect one of them from the PC and connect it to the Rpi they start flashing again.
i also decided to move on and connect with UDP for now.
BTW. i am still using Arducopter 3.6.11. could the new Arducopter 4.0.4 fix it ?
how can i upgrade to that ?


another thing… can’t we just replace the telemetry with xbee modules ?