launchSitl link timeout


Hi there,

I’m stuck on lecture: “Script to Automatically Launch QGC with DroneKit Script part3”

When I run launchSitl, I get the following output:
jason@dronebox:~/DroneCourseRoot/dk$ launchSitl
os: linux, apm: copter, release: stable
SITL already Downloaded and Extracted.
Ready to boot.
Execute: /home/jason/.dronekit/sitl/copter-3.3/apm --home=44.5013,-88.0622,0,180 --model=quad
Started model quad at 44.5013,-88.0622,0,180 at speed 1.0
bind port 5760 for 0
Starting sketch ‘ArduCopter’
Serial port 0 on TCP port 5760
Starting SITL input
Waiting for connection …
bind port 5762 for 2
Serial port 2 on TCP port 5762
bind port 5763 for 3
Serial port 3 on TCP port 5763
>>> Link timeout, no heartbeat in last 5 seconds
>>> No heartbeat in 30 seconds, aborting.
Traceback (most recent call last):
File “”, line 61, in
vehicle = connectMyCopter()
File “”, line 22, in connectMyCopter
vehicle = connect(connection_string,wait_ready=True)
File “/usr/local/lib/python2.7/dist-packages/dronekit/”, line 2845, in connect
vehicle.initialize(rate=rate, heartbeat_timeout=heartbeat_timeout)
File “/usr/local/lib/python2.7/dist-packages/dronekit/”, line 2117, in initialize
raise APIException(‘Timeout in initializing connection.’)
dronekit.APIException: Timeout in initializing connection.
/usr/local/bin/launchSitl: line 18: kill: (13151) - No such process
/usr/local/bin/launchSitl: line 19: kill: (13155) - No such process
/usr/local/bin/launchSitl: line 20: kill: (13159) - No such process
jason@dronebox:~/DroneCourseRoot/dk$ Closed connection on serial port 0

Any idea what’s going on?


Be sure the screen dependency has been installed.

Please let me know if this helps so we can learn together.


I am hving the same issue so comented out “screen -dm” and used & at end of the syntax
and anyhow got the same message. How does one istall the screen dependency ?
It seems I must root…



Came right . in order to fix install apt-get install screen


Hi…i have installed the screen dependencies and it was working for a few days.
But now i am getting the same error again…any idea what i should do?
Please help


If software is working, the only way it would stop working is if something was changed, right? The computer is simply following the instructions.

Either some code was changed or perhaps you have a corrupted file because linux was shut down improperly, etc. There was also some warnings not to update some sw because Caleb did not test the system for other sw updates.

I would back up a few steps and do it over. I have actually re-installed everything several times because I couldn’t solve a problem, then it would work.

Warning: Dronekit is still not solid, and I’m not seeing a lot of support. Drone Code, for example, works for PX4 (not Ardupilot), now has momentum and supported by Lorenz Meier in Switzerland.


Hi…try a different network. It’s possible that perhaps a network configuration is creating an error. Is this your first time experiencing this issue? Have you had Synergy work before this issue? If so, what can you think of that has changed right before you started experiencing this issue that could cause it? This information will help us help you troubleshoot your issue and reach a solution.