launchSitl "can't find '__main__' in module in ' ' error


#21

Can you post your requirements.txt or requirements.in that you are using on your most updated linux version? Thanks. I’ve spent hours arguing with my python venv.


#22

Sorry for the long delay Jax.
I got tied up with actual work. I emailed you the scripts I have tried to use.
None are able to launch the Simulated Drone.


#23

I gave up on the virtual environment. no combination worked, even the same combination as the one provided in the documentation fails.
I upgraded to Ubuntu 20.04 LTS and use the latest python3 libraries. The DroneKit Software is to say it politely, in need of upgrading. And to be honest the entire video and documentation provided in these courses is so far behind, it made thing more difficult to implement, that if I just did it on my own. I literally invested hours on these for very little gains.


#24

There are a number of errors in your code, some insignificant, some significant. Once they are corrected it will work. As you know, in coding a very small thing can bring down a big thing.

The most significant, which is Reason #5 in my blog on connections, was a missing ‘tcp’ argument:

Other errors were: