SITL Drone Introduction Video


Hello Experts,

I’d been following the video list in the drone programming course SITL Drone Introduction video(Simulated Computer drone) when something I could not figure out why the console window and the map widow did not appear after compiling the arducopter firmware from the command --map --console.

Checkout my full screen desktop screenshot missing console & map window. I hope anyone can help.



“ImportError: No module named wx”

try locate

might have to re-install mavproxy?



Just like you said, I found the file in my specified directory. From that point, what shall I do next? So I just assume the file exist so, I goto next step…

Reinstall MAVProxy1.6.2, try the command again: --map --console but still the same- No map, No console.

Then I upgrade it by typing command pip install --upgrade pip - same problem.

ImportError: No module named wx

Do you have another solution? Thanks for helping…


I just took this course as well, so no expert… But I have been successfully running the bash scripts.

Caleb warns in the video not to upgrade pip, as it might cause problems.

After installing mavproxy, did you run:
sudo usermod -a -G dialout $USER
sudo apt remove modemanager

If I encountered this issue, frankly I would reinstall everything starting with ubuntu. There are a number of steps where a slight mistake could mess you up.

Make sure you have entered all the required dependencies.

As a side note, the video didn’t include the screen dependency, which is needed for the bash commands.


I post this question to this link, cause it relates to the SITL Drone Introduction Video.

I’m able to launch the file with --map and --console options.

My problem is that I’m not able to see the “view” menu to select a map and therefore not drone neither map appear.Capture

Help to solve this issue is appreciated as I’m not able to progress without seeing the map.

Thanks in advance for your help!


Sorry for the above message.

I’ve managed to solve the problem myself. I’ve seen that the view menu appears attached to the console tab, so no problem any more

Kind regards,


I was wondering if anyone ended up solving this? I’m halfway through 2020 and having this issue as well as my map and console are not showing up.


I just tried installing the pre-configured package from Caleb and all good. I assume then you instead tried to build it yourself per the lecture? Remembered to not upgrade pip? What versions pip, ubuntu, MAVProxy, Copter and python are installed? Could you provide a screenshot of your command and resulting messages?