One motor does not spin


I soldered the motors to the power distribution board and all the soldering points look fine. But one motor isn’t spinning (it is just moving a bit). First I thought it would be because of the red wire from the ESC being plugged in into the pixhawk. When I removed the red wire the ESC didn’t get hot anymore but the motor still isn’t spinning. All the other three motors work fine.
Does anyone have an idea how to solve it?

Thanks and best regards


Well first off, don’t solder your motor to anything ; ).
I know you meant the esc.
The ‘red wire’ power feed from the esc to the fc is just to power the rail or provide backup power to the fc, and doesn’t have anything to do with powering the motor.
Reasons for not working as you observed include:
1 esc not properly calibrated (easiest to test)
2 Obstruction (eg, debris, screw) is preventing movement (does it move freely manually?)
3 Defective esc or motor (try switching esc and motor)
4 Bullet connection not good (check for good bullet soldering and good connection)


@jax200 Thanks a lot for your help. The ESC calibration was fine and it also moved freely manually but the motor doesn’t work… :frowning: I tried it with another ESC with the same result.

2 ESCs beep 2 don't - [solved]-ish

Sounds like you have a bad motor.


I have had a similar problem with #1 motor. After conferring with Caleb, I used my xacto knive to clean the contacts inside of the esc and reinserted the motor connectors. Then the motor would spin. I had a minor crash in testing this week, and found I had to do it again. I thought I needed a motor like you, but after connecting a different motor (and having it spin) I found cleaning the inner contacts resolved it again.


Good feedback.

closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.