Cannot connect to drone via internet


Im at the course “connect drone to MP via internet only”
I am able to connect using the MP interphase but unable to do it via scripts.
read an older blog here but could not make it happen.
I also followed the steps in the youtube video “make your own pixhawk rpi dorn in 36 minutes”.
following the steps in the youtube video, I did change the RPI config tool ad also edited the boot/config.txt file.
when I connect the rpi to power, the pixhawk does get power too.

this is what I get with /dev/ttyAMA0 (youtube video)

pi@raspberrypi:~ $ --master=/dev/ttyAMA0 --baud 57600
WARNING: You should uninstall ModemManager as it conflicts with APM and Pixhawk
Connect /dev/ttyAMA0 source_system=255
Log Directory:
Telemetry log: mav.tlog
Waiting for heartbeat from /dev/ttyAMA0
MAV> Detected vehicle 1:1 on link 0
online system 1
Mode(0)> Mode Mode(0)
fence present
AP: ArduCopter V4.3.3 (34e8e02c)
AP: ChibiOS: 66e5de0d
AP: Pixhawk1 00410041 30365115 31313731
AP: RCOut: PWM:1-14
AP: IMU0: fast sampling enabled 8.0kHz/1.0kHz
Received 936 parameters (ftp)
Saved 936 parameters to mav.parm
AP: GPS Glitch or Compass error
AP: EKF variance
AP: PreArm: Motors: Check frame class and type

this is what I get with IP (dojo course)

pi@raspberrypi:~ $ --master=
WARNING: You should uninstall ModemManager as it conflicts with APM and Pixhawk
Connect source_system=255
Log Directory:
Telemetry log: mav.tlog
Waiting for heartbeat from
MAV> link 1 down

for this modemmanager error I did disable it, same error
sudo systemctl disable ModemManager.service


The warning says to uninstall it, not to disable it. The course specifies:

sudo apt remove modemmanger

Wondering if you missed other steps?


Jax, thank you for the reply,
I wonder if I did miss something?

was not able to find the course mentioning to remove modemmanager
course “how to build rpi > initial setup of drone > step 7 connecto drone to MP via Internet only”

was not able to see the youtube video mentioning it either:
(8) Make Your Own Pixhawk Raspberry Pi Drone in 36 Minutes (2020) | The Ultimate Project Drone - YouTube

when I run your command, modemmanager error goes away :slight_smile:
but the rest of the output remains the same “Mav> link 1 down”

more info:

  • changing the baud rate, no luck,
  • I am in a windows laptop,
  • used the easy raspberry pi imager
  • the RPI does connect to wifi because I can see it in the advanced ip scanner


You might consider looking over this blog :

Funny, but I do not see the steps I am thinking of in the RPi build video. I followed them from the programming course:



I like the article you shared, I have followed up the steps and still no luck:

  1. “Wires”
    Double checked that the wires are connected correctly from Pixhawk to RPI,

  2. “SW loading”
    run the commands on step two again

  3. serial interface
    already enabled serial port in RPI as step 3.
    Would you like a login shell to be accessible over serial? NO
    Would you like the serial port hardware to be enabled? YES

  4. bt overlay
    already confirmed configuration in boot config file

  5. mavproxy statement
    used the same statement as the course video,

  6. baud rate
    attempted multiple baud rates, from minimum to max, no luck, heres a couple examples

  7. not sure what to do here but I think we are using serial 2 and we can see is set to MatLink2 and 57600 baud,

  8. COM port,
    not applicable here since we are using IP?

couple notes:
-If I power the RPI, the pixhawk does power,
-Using RPI imager,
-My mission planner arducopter is newer compared to the one shown in the video.
-I am able to connect the Mission planner using USB link, if I tilt the drone, the horizon moves and I can see the map showing my house location.
-I have been unable to power the motors with the RC controller, the manual calibration didn’t work, the calibration through mission planner I think didn’t work.
-all other pins/wires in pixhawk or RPI have been disconnected/connected to make sure no lose cables



Did you try Motor Test in MP?

Also sounds like you need to get the receiver sorted out with the transmitter. Could be a problem how the transmitter is configured or/and how the receiver is wired



I think we are closing in the issue here.

Almost 100% sure is not an issue with TX/RX. watch my youtube video on showing how they seem right (to me):

Followed the steps on how to connect RX and bind to TX here:
Bind Receiver and Transmitter (X6B Receiver) - Drone Dojo (

Followed steps on how to configure TX here:
Setting Up the RC Controller - Drone Dojo (

My video shows that the pixhawk does connect to MP via USB and not via Internet. Motor Test in MP only makes music in pixhawk but doesnt spin the motors. the battery is connected and has full charge. Confirmed that the motors are receiving charge and are even pulsating a little bit. Checked that the screws are not over-tight, watch this second youtube video:

checked all the cables to pixhawk, so far I believe the pixhawk hates me.


Regarding motors:

Are you able to connect to MP via Telemetry?

If so, go to the Messages tab. What does it say when you try to arm the drone?

This tab 99% of the time tells you why the drone won’t arm

Regarding internet connection to MP:

What is the IP address you are using after --master?

On the pixhawk drone, the only way to connect with mavproxy initially is the UART bridge, with /dev/ttyAMA0



Regarding motors:
Are you able to connect to MP via Telemetry?
Yes, per your recommendation, I read the MP messages tab where it said I didnt have a frame configured, solution:
MP > setup > hardware > frame type, selected quad
A following error didnt allow to arm because it said I was missing a compass,so I just removed it:
MP > setup > hardware > compass > remove missing
then start the calibration with the steps shown in the course

Regarding internet connection to MP:
I was able to then connect using /dev/ttyAMA0.
the course video how to build RPI drone > initial setup > connect drone to MP via internet
shows the steps on connecting using IP, is that only for Navio?

all that said, I thank you both for helping me move forward, I was able to make it work! :slight_smile:
a recommendation I would give other folks is that when hitting roadbloacks during the course, watch the following videos because issues can be solved by the information in videos you haven’t watch yet.


In my head, here are the ways to communicate to the pixhawk drone:

  1. using the RC controller.
  2. connecting the Pixhawk to laptop USB
  3. connecting the Pixhawk to laptop with RX/TX transmitter
  4. connect through the Raspberry PI dev/ttyAMA0 port

closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.