Unable to submodule mavlink - tried altering 'git' to 'https'


When running git submodule update --init --recursive I am getting the following error for pymavlink:

Screen Shot
All of the other submodules worked as far as I can see. The issue is just with mavlink.

What have I attempted

I was having this issue with all of my submodules and altered the .git/config file so that it uses https:// as opposed to git://; however, this issue hasn’t resolved for mavlink.

I’m now on my second VM, I decided to try again from fresh in-case I messed up any of the VM setup.

I have attempted it without my Windows Firewall on.

I don’t understand why it would be using git:// after I altered the config file?

I’m not sure what other options I have to resolve this?


For if it’s a dependency issue here’s my pip freeze:


Perhaps this earlier thread might help:



can you try:

git config --global url.https://github.com/.insteadOf git://github.com/


Thank you, Ricardo.

This has resolved the issue.

As well as your suggested git config --global url.https://github.com/.insteadOf git://github.com/ I also ran git config --global url.https://github.com/.insteadOf git@github.com/

I’m guessing there must be another git config file somewhere that is not ardupilot/.git/config


Nice, so does that mean you have everything working under Python3?

I was thinking that we are a bit out of date, Python2 has been depreciated. I might try another VM and update to Ubunto 20 and Python3 in that case :slight_smile:


I am now experimenting at 22.04 w python3.

See. https://community.dojofordrones.com/t/full-gz-sim-on-22-04-lts/805/6


Brilliant, I’ll have to give upgrading a go once I’ve completed the course.