Trouble enabling servo


Attempting to run “python”

Keep getting error message about the failsafe:
“WARNING:autopilot:GCS Failsafe Cleared”
And servo doesn’t budge.
Not really sure what to make of this. Thanks for any help.


Are you executing this script while connected to Mission Planner - hence the message? It’s normal, not to worry.

Are you using a Navio or Pixhawk?

Regarding why the servo is not working, I’ve found it could be any or all of the following:
1 Execute with the LiPo installed, as power from the USB alone might not be enough to move it.
2 Ensure the servo moves freely - I had an issue where it wasn’t moving until I did that.
3 Ensure the servo is properly plugged in, minding the correct direction, eg, for the Pixhawk the signal lead is downward.
4 Ensure the correct parameter is set in Mission Planner, eg, for SERVOx_FUNCTION=0.
5 Ensure the code reflects the corresponding pwm servo connector you have plugged in.



Hi @jax200,
Thanks for your help.

I did try your steps above, and still can’t seem to find the issue. I am using a Navio 2. I tried with the LiPo, made sure the servo moves freely, double-checked my code against Caleb’s, made sure orientation of wires were plugged in correctly to servo rail.

The only thing I was confused on is maybe I need to correct the parameter in Mission Planner, like you mentioned. I have my servo plugged into number 14 on the servo rail. Should I set SERVO14_FUNCTION parameter to zero in MP?


Yes, do that.


Hmm looks like it was already set to zero. I tried it in slot 13 on the servo rail and changed my script to accommodate, still nothing. I’m wondering if I just have a defective servo. I did notice the “GCS Failsafe Cleared” messages aren’t coming through anymore though.


I’m not a Navio user, so not sure what else to suggest, other than you can put the servo in the receiver and try to simply move it with the transmitter to see if it is good or not. I think it will provide enough power for those little servos.


Were you able to figure this out @Jspatafore49?

Do you have a multimeter? If so try testing it on the servo rail to see if your are getting 5V. If not, make sure you have a ESC UBEC (red and black lines) connected to the servo rail. Also make sure the connector on your servo is in the correct position. You may also try powering the servo on its own to see if you can get it to move. Another thing to check is that you get the numbering correct of the servo slot you are plugging into.

closed #8