Problem displaying Mission Planner on HighDpi monitor using Mono


Virtualbox, linux, Mission Planner, mono, telemetry, highdpi monitor

I strictly run Linux. on a high-dpi laptop. Trying to run Ardupilot Mission Planner with mono wasn’t working out because of the high-spi display, which was displaying everything in an unreadable format.

If anyone knows a trick to get MP to display correctly in linux, please let me know because it might negate all of the below rigmarole.

My solution was to run VirtualBox with a win10 image, install MP on win10, and then map the usb of the laptop (where the telem was plugged in) to the serial connection in VirtualBox.

In linux, plug in your USB telemetry install Oracle VirtualBox(VBox), install the extension pack (I’m not sure if you need this, but…), download a win10 iso and mount, install, and setup win10 in Vbox.

Then, stop the box and go to vbox settings for the win10 box and go to the box settings and go to Settings/SerialPorts/Port1/EnableSerialPort and com1 and port mode=Host Device, path address should be /dev/ttyUSB0 or /dev/ttyUSB1
Restart win10, and your telemetry should be there!

I haven’t tried flashing firmware and I would be super wary of that.