Pre arm, 3d accelerometer calibration needed


Hi everyone!

I tried connecting QGC to SITL and got this message

along with the audio error saying “pre arm, 3d accelerometer calibration needed”.
I also got this message on the console highlighted in red saying INIT GYRO***

has anyone faced the same issue and know how to solve it? Thanks! :slight_smile:


I do not understand - have you tried ignoring the message or upgrading the fm? Then just calibrate the IMU? That is what it seems to be saying.

btw, how did you upload an image to your question? I forgot how!


Hey jax200, thanks for the reply!

oddly enough the problem seems to sort itself out the second time I logged in :thinking: but i do want to try updating the firmware though, can you explain how I can do it? is it simply by installing the latest firmware the same way like it’s taught in the course and it will automatically overwrite the previous version, or is there any other steps i need to take?
As for how i uploaded picture, I used snipping tools co capture the problem, copy the result, and hit ctrl+v in the place you write the thread and it’ll automatically upload and give you the link


Yes, just as Caleb showed. Copter 4.0.7 is the latest. If that is what you have then you’re fine.


Looks like my image upload worked. Thought I tried it once before with no luck. Thx!


Hi there @AgastyaB

You can safely ignore the QGC message, it just wants you to udpate to the newest version, old version is still valid.

As for the other errors you mentioned, they aren’t so much errors as they are a part of the normal startup sequence for any ardupilot vehicle. They should go away with enough time if you’re running the SITL vehicle.

closed #6