No signal from RPI to monitor


I have my RPI drone connected to the monitor using the HDMI,

this used to work no problem until one day the monitor is showing no incoming signal. Tried both RPI4 HDMI outputs.

*Confirmed that RPI is up and running because I can SSH to it using Putty and all my files are there. the Drone is always safe indoors.
pi@ricardopi:~ $ vcgencmd get_throttled

*Confirmed that the monitor and monitor’s cables work with other devices. (Even tested multiple monitors). RPI has monitor “headed” enabled:
pi@ricardopi:~ $ systemctl is-active

pi@ricardopi:~ $ systemctl is-active display-manager

*Confirmed that the power cord worked and tested multiple cords. Voltage looks healthy:
pi@ricardopi:~ $ vcgencmd measure_volts core

Any ideas?


Been there done that. I always try to reset a monitor first. Certain monitors are very picky about the order of powering on for doing resets. Consult you monitor docs.

You are using a RPI OS of Ubuntu Desktop correct?

Have you used raspi-config before this occured and set video/display/HDMI correctly?

Never tried SSH in and use this tool but if you can get it to work remotely, you have a shot at confirming setting and tweking them if needed. You can get the video port selected, sound pipied through HDMI etc.

Gook luck.


You tried it on a different RPi?
I see there are discussions related to this at the RPi forum. But you probably already checked there :slightly_smiling_face:.


unfortunately I dont have another RPI, but the monitor does work with laptop, etc. Same laptop the same RPI used to work before. do you mind sharing which RPI forum this conversation is at?


Yes, reviewed the raspi-config and display is enabled,


Not sure what happened but started working again, will keep you posted in case I can discover what changed.
My first guess is that I have “too much stuff” connected to the RPI so will see.


closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.