*newbie question* Failing pre-arm checks after succesful build and MP firmware update


Hi all,

I purchased the Drone Kit here and completed all the steps without deviation or customization described in the “How to Build a Raspberry Pi” course.

After downloading MP and updating the firmware, I get a blinking yellow light (I assume for failing pre-arm checks GPS:Bad Fix)

In MP:
-Preflight Tab shows Verifying GPS and GPS Sat count in red

I’ve left my drone outside for an hour without obstructions. Any ideas?


Assuming you have a clear view of the sky it should work. Try the simple fix first by unplugging/plugging the GPS connections - is the LED on? Is the GPS located on the drone so there is no electromagnetic interference? Do you have another GPS you can switch out with?

Check the MP Messages tab and see if it reports GPS.

Check the MP GPS parameters. For example, set the GPS_AUTO_CONFIG to 1, GPS_AUTO_SWITCH to 1, GPS_BLEND_MASK to 5, and GPS_BLEND_TC to 10, GPS_TYPE to 1. I have read setting BRD_BOOT_DELAY to 3000 might help. Are SERIAL3_PROTOCOL and SERIAL4_PROTOCOL set to 5?

Aside from that the GPS module HW or FM might be messed up, or the connection to the Pixhawk FC.

closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.