Mission Planner PreArm Error Message


Does anyone know what this means and how to resolve it? “PreArm: Motors: Q_M_SPIN_ARM > Q_M_SPIN_MIN” When reviewing the two parameters, they are set to their defaults and have not been changed,

I can’t get the motors on my 4+1 VTOL to work. I’m using the Orange Cube with Radiomaster TX16S Radio Transmitter and Bandit BR3 Receiver. Even when I manually ARM the system using the button on the Actions Tab on MP or attempt to do a Motor Test, its still a NOGO.

Any ideas?


According to https://ardupilot.org/plane/docs/parameters.html#q-m-spin-arm

Q_M_SPIN_ARM is the point at which the motors start to spin when armed, whereas
Q_M_SPIN_MIN is the point at which the thrust starts.

This is a safety check to prevent the motors from spinning at a speed higher than what is considered safe for arming. To resolve this, you need to adjust these parameters so that Q_M_SPIN_ARM is less than Q_M_SPIN_MIN .

The Q_M_SPIN_MIN should be set to a value that is at least 0.03 higher than the Q_M_SPIN_ARM https://ardupilot.org/copter/docs/set-motor-range.html
For example, if Q_M_SPIN_ARM was set to 0.09, then Q_M_SPIN_MIN should be set to at least 0.12.



Further Clarification

Thanks for your response jax. I’ve seen your recommendation in my search for an answer to my dilemma and it makes absolute sense however I looked into multiple VTOL aircraft from several different types and all of their Q_M_SPIN Parameters seem to be configured the same as mine. Does this help define the problem any better? I will change the Q_M_SPIN_MIN from 0.15 to 0.23 and see what happens. I’m curious why I don’t get this same error on any of my other VTOL aircraft.

Name Value Options
Q_M_SPIN_ARM 0.2 0.00: Low, 0.10: default, 0.2: High

Q_M_SPIN_MAX 0.95 0.90: Low, 0.95: default, 1.0: High

Q_M_SPIN_MIN 0.15 0.00: Low, 0.15: default, 0.25: High


Not sure about the others, but the change should work.