Mavproxy installation in ardupilot installation 1


Hello getting the following error when i run sudo pip install MAVProxy==1.6.2. I am following the drone primer porgramming course . Please help. When i try to run sudo pip install --upgrade pip i get the same error



I ran the following steps using Virtualbox with minimal option Ubutnu 18.04, and had a good install. Try a fresh start and let me know what you did differently.

1 sudo apt update
2 sudo apt upgrade
3 sudo apt install python-dev python-opencv python-wxgtk3.0 python-matplotlib pythonpygame python-lxml python-yaml vim git screen
4 sudo apt install python-pip >> confirm using pip --version (Note: Do not upgrade pip)
5 sudo pip install MAVProxy==1.6.2

And confirm the versions


Thank you so much . Your Steps aided me to set up the SITL drone and i have connected it to QGroundControl station. Please i would like to know whether i can see sensor values on the simulated drone or i would need to use a physical drone before i can see sensor values. Specifically the rangefinder sensor


In the SITL run

param show rng*


I have set it up based on the ardupilot documentation . But when i load the graph and test flight with the SITL nothing appears on the rangefinder graph. It does not graph anything . I also noted that on the ardupilot documentation it is Rangefinder 1 but on my SITL params list it is Rangefinder 2