How to calibrate the newer ESC


I was told to calibrate the ESCs I got to get the drone working. These ESCs are slightly different (they appear to be the replacements for the older ones) than the ones provided by the course but I was assured they should still work after they are calibrated. However, Idk what I’m doing that is wrong when calibrating.

Here are the ESCs I got:

Here is the manual:

This differs from the one provided by this course which has the label “NIMH:5-12S LIPO:2-4S” on the esc instead.

The one provided by the course works (motors give a beep when powered on), while the ones I got do not work (no sound).

I was able to get the X6B receiver to display a solid red and have it hook up to the controller. However, I wasn’t able to calibrate following the tutorial. In the tutorial it was mentioned hitting the safety which I don’t have. Also interestingly is that there are more lights coming from the pixihawk when its turned on. My drone doesn’t give off any motor sounds either when turned on (Idk if this is because its not supposed using these new ESCs or because it hasn’t been calibrated yet). I will have picture to show you what I mean in the reply section.


To make it easier to read, here is the left-top half (Part 1 of 4) with greater magnification:


To make it easier to read, here is the left-bottom half (Part 2 of 4) with greater magnification:


To make it easier to read, here is the right-top half (Part 3 of 4) with greater magnification:


To make it easier to read, here is the right-bottom half (Part 4 of 4) with greater magnification:


Here is the image. Plz note that the ACT light was also blinking blue as well (couldn’t time it right so that all the lights were on at the same time). The yellow light on pixihawk was also blinking (stable/solid green lights too). But you can see the stable/solid red light from the receiver and that it is paired with the controller (IntV1 and SigS1 readings on controller).


I have these ESCs on one of my drones and it doesn’t emit motor sounds like the others until I push the safety switch. You might consider ordering this. I also use the calibration procedure in Mission Planner.

Alternatively, and I’m not 100% this will work, you can uncheck the ‘Hardware Safety Switch’ option in Mission Planner.

The FrSky X6B should have a solid green LED when bound to the transmitter. Solid red indicates it is not bound.


Ok, so just for clarity I shouldn’t consider following the procedures in the video “Calibrate ESCs (X6B receiver)” for the purpose of binding the transmitter to the receiver? But I don’t understand this because in the video the receiver is solid red and you are able to control the motors after following those procedures, so what am I misssing?

Also I now have the safety and buzzer.

The following link is a video of my attempt. Maybe you can see if I’m doing anything wrong? If not, where should I go from there (i.e. what videos should I watch?)

Thankyou for the quick previous response.


I stand corrected. All of my FrSky receivers are green when bound. The video is not working for me, so I cannot comment. But when you pressed the switch did it come alive?


Here are the steps I took in the video.

  1. Power on controller (the left stick is in the bottom position)
  2. Move left stick up
  3. Plug in battery -> I hear a short beeping sound -> then I hear a longer higher pitched beeping sound
  4. I press on the saftey button
  5. I unplug the battery -> controller gives beeping sound (becuz its disconnected)
  6. Plug in battery -> I hear a short beeping sound -> then I hear a longer higher pitched beeping sound
  7. I press on the saftey button
  8. Move left stick down -> Nothing happens

So unfortunately nothing comes alive.


It appears different from the link I sent. Try following the steps exactly (ie, remove steps 4-6), or better try the MP procedure.


I tried do the steps (except 4-6) and it still failed to work. I’ll try the MP next.


I should have a response by tomorrow hopefully.


I watched your video and saw, that after you hit the safety button it is still blinking and has not the constant light as it has in the video tutorial.
When I calibrated my ESCs I had the same problem and in my case the solution was to press the safety switch a bit longer until I saw the constant light.


Worth a shot


Unfortunately holding the safety button didn’t work.


I also had to try a couple times… I waited a day and then tried again and it worked, but I made sure to follow the tutorial perfectly. The key is to hold down the safety switch until the light is solid.


I’ll try again