GPS Not Working


So my drone crashed yesterday, and now my GPS is not working. My first instinct was to simply replace the GPS model with a new one, which I did. But it’s still not working. My second thought was that there is something wrong with the pixhawk shield itself, so again, I replaced it. Still not working. I am scratching my head here…what else could I do?


I recently had the same issue - no idea why it suddenly stopped working.

The problem - and solution - was the GPS_TYPE parameter mysteriously changed to “4”. Changing it back to “1” cleared this up.



Thank you. Do you know how to change a specific parameter such as the GPS_TYPE?


Install Mission Planner on your computer and connect via radio telemetry as per the lectures.

Once connected, go to CONFIG, “Full Parameter List”, and type “GPS_TYPE” in the search bar (arrow).

Ensure the value is set to 1, then click “Write Parameters” so it is saved to the vehicle. It should then show a connection to the GPS seen in the DATA tab.

Let me know how it goes.


BTW, I didn’t address the fact that this happened after a crash. This was not the case with me, so it could be something else, but you said you replaced the components. Also, pixhawk is a type of flight controller, not a ‘shield’.