Git submodule update --init --recursive


git submodule update --init --recursive

Cloning into /home/abhisehk/courseRoot/apm/ardupilot/modules/ChibiOS’… fatal: unable to connect to[0:]: errno=Connection timed out fatal: clone of ‘git://’ into submodule path ‘/home/abhisehk/courseRoot/apm/ardupilot/modules/ChibiOS’ failed Failed to clone ‘modules/ChibiOS’. Retry scheduled Cloning into ‘/home/abhisehk/courseRoot/apm/ardupilot/modules/gbenchmark’… compilation fails_Something about GPS task

Not sure but try searching a bit on the forum or internet. I found this that might help:


I was having the same issue. It has issues working with git but in my case everything was working fine when I manually downloaded these modules using HTTPS. However, when I came to actually simulate, it failed due to some reason. I opened port 9418 (if I remember correctly, the one for git) and a couple more, but nothing worked.
What worked in my case is the following sequence

  1. I started off working with an entirely new folder/directory
  2. I initialized these submodules during the download of the Ardupilot using the following command
    git clone --recurse-submodules
    It means download ArduPilot and initialize the submodules at the same time. Then carry on with the usual commands
    Moreover to visualize I am using QGC rather than the mission planner. I am working on Ubuntu 20.04


Below fix my error.
git config --global url. git://
git submodule update --init --recursive