Flashing firmware problem


I am new to drones and relatively new to the Raspberry Pi. I just built my Raspberry Pi drone. I was a little confused because the Raspberry that came with the kit did not have a microUSB slot. So I simply went to flash Mission Planner to the Pixhawk 2.4.8 directly via a USB connected to my laptop (independent of the Raspberry Pi) with Raspberry Pi unplugged from Telem2 just to see if I could get the props to spin.

I have Mission Planner 1.3.74 installed to my laptop. In Mission Planner went to Setup > Install Firmware > Copter 4.0.7, with the correct COM port selected and 115200 baud rate. After pressing the quadcopter Copter 4.0.7 Official icon a window popped up asking about Platform and Firmware. I selected Platform > Pixhawk1 and Firmwares > https://firmware.ardupilot/org/Copter/stable/Pixhawk1/arducopter.apj; and then pressed Upload Firmware. Note: The first time I tried this I did not have a microSD card in the Pixhawk. Everything seemed to flash correctly.

However, when I press the Connect link in the upper RH corner of the window, a new window pops up that states “Connecting Mavlink”, then to “Progress”, and then “Getting Params 1”. After everything progresses through and popup goes away, the screen states:

"You cannot load new firmware while connected via MAVLink.

Please press the Disconnect button at the top right to end the current MAVLink session and enable the firmware loading screen." (With an additional sentence with a Bootloader Update button as follows):

[Bootloader Update] Update the bootloader on your hardware to the newest available."

This is a little over my head. All that is currently plugged in to the Pixhawk is the buzzer, switch, GPS, I2C (from the GPS heading), and the power. The battery is unplugged and the Pixhawk is only getting power from the USB connection. Can someone give me some guidance on how I get properly connected and can verify that my firmware is correct?


All, I think that I solved my problem. I just ignored the “You cannot load new firmware while connected via MAVLink.” that I received on the Setup > Install Firmware page and just continued on down to Setup >> Mandator Hardware.

For now, I still have the Raspberry Pi disconnected from the TELEM2 port on the Pixhawk 2.4.8 and am connecting via a USB cable from my PC (COM port with 115200) to the Pixhawk. I also have the telemetry module that came with the drone kit plugged into the Pixhawk and in a the PC-side telemetry module plugged into a different USB port.

I did get the rotors to spin before the day is over and got the drone 6 ft in the before a relatively rough landing that knocked my telemetry antenna loose. It does all still seem to be working. That went from unboxing to first flight in one day. I plan to start a new thread titled Raspberry Pi drone for the Newby, where I will open up the discussions to problems that I am having and solutions that I come up with and assistance that more experienced drone builders can give.