Failed to load defaults (and 3d Accel calibration needed)


Hi everyone!

I’ve been trying to follow along the " Connecting MAVProxy to SITL Drone" course video and I got the following error when I tried to run the SITL

I tried multiple times to check if I made a typing error that specifies the default params, yet I still got the error saying “failed to load defaults”
I also got the following pre arm warning that prevents me from arming :

is this related to the “failed to load defaults” error? and if so, how can I solve this?

Thanks in advance!


I believe the problem is your path to the copter.parm file, If you enter “cd /home/courseRoot” in a terminal, you should get “bash: cd: /home/courseRoot: No such file or directory”. If you use “/home/abagaskara3/courseRoot/apm/ardupilot/Tools/autotest/default_params/copter.parm”, I think your problem will be solved.

This works:
(drone) david@hp-office:~/courseRoot/apm/ardupilot/build/sitl/bin/arducopter -S -I0 --home -35.363261,149.165230,584,353 --model “+” --speedup 1 --defaults /home/david/courseRoot/apm/ardupilot/Tools/autotest/default_params/copter.parm
Started model + at -35.363261,149.165230,584,353 at speed 1.0
Starting sketch ‘ArduCopter’
Starting SITL input
Using Irlock at port : 9005
bind port 5760 for 0
Serial port 0 on TCP port 5760
Waiting for connection …

Good luck.


that solved it, thank you so much


10 points @dsetin19

closed #5