Emlid preconfigured release and Dronekit connect timeout


I recently posted a question about a connection timeout in even the simplest Dronekit script. After beginning to think that maybe it’s a problem with the Emlid 2019-11-28 OS preconfigured release I did some searching and found a post on the Emlid forums detailing this problem and a response from Emlid in March indicating that they would look into the issue but so far no updates. I built my Drone around a Pi 4. My thinking was based on info I found on the web that older images won’t work on the Pi 4. Is anyone using Dronekit on a Pi 4 using this Emlid image from late 2019 successfully? I would like to base my Drone on a Pi 4 running Buster if at all possible. I suppose I could rebuild the Drone using a Pi 3 if absolutely necessary.

I would like to get Dronekit working on the latest Pi and Raspian that I can. I would appreciate any information from people if there is a Pi 4 combination that works. Any other suggestions on how I can get my Drone Dojo Drone running Dronekit into the air would be appreciated.



Problem Solved – Ok, I solved this problem by pulling the master branch from the repository and building it locally. I then set my locally built arducopter image to be ardupilot firmware controlled by the service as described in the Emlid documentation. Dronekit Vehicle.connect methods no longer timeout. Life is good.


Glad to hear your problem is solved!
Happy flying djrounds


I just received my Navio2 and was thinking of a Pi4 for it. Good to have this info. It will be a while before my quad build and don’t know which Emlid preload I got.