dronekit.TimeoutError: wait_ready experienced a timeout after 30 seconds


In Drone programming primer course, function to connect python script to sitl drone part 1, there is a python script which tries to connect to sim_vehicle. But when I run the script with command:

python connection_template --connect I get error: dronekit.TimeoutError: wait_ready experienced a timeout after 30 seconds.

Note: sim_vehicle has been started in ArduCopter.

I have attached python script text.


Have you seen this:

Try searching this forum for ‘timeout’. It appears you are using python2, but perhaps you will find something.

Also be aware there are some version issues with dronekit-sitl and pymavlink as explained in the course.


I installed python 3.6, and tried to run, but got same error. While I was looking online for solution I found this: https://dronekit-python.readthedocs.io/en/latest/develop/installation.html

dronekit does not have support for python3. How are other people running dronekit with python 3?


Remove ‘import exceptions’, as it is not compatible with Python 3.