Compass calibration question


As long as im on here posting i’ve another question perhaps you can shed some light on.

When I was calibrating the compass according to the videos, I was unable to calibrate using compas 1. While rotating the drone, mission planner would beep like something was happening, but the bar would not fill. when i tried using compas 2 it worked fine.

The drone will go “ready to arm” (although I can arm it due to the other topic i posted) so I guess its getting all the data it needs, and rotating the drone rotates it on the map.

A few things have been different from coarse to actual so far, so i am wondering if this is a change in SW version since then or something. on mine compass 1 shows as external and 2 as (not checked as external) ill include a screen shot incase that provides any info. I dont think this is blocking me, but just wanted to check.


You state the external I2C compass with priority 1 did not work, yet it is checked. And the internal SPI compass 2 did work, but it is not checked. So this is confusing.
What are COMPASS_ENABLE and COMPASS_USE set to? What happens if you disconnect the external compass first and you try to calibrate it? Look at MP MESSAGES to see if there is a clue.


I took the check in the top section in the I2C row to indicate that the compass is external, not that is is selected. I didn’t add that check, I thought the check was to tell me that its external. Am I misunderstanding that? I see that I should probably move the SPI one up in priority if its the one that passes the test though.

Below that is where I thought I was actually selecting which ones to use and where I encountered the problem with the bar not filling, where it says “use compass 2”.


You are correct, I was reading too quickly. The check designates external. And you are using just internal. So you are asking why the external compass did not calibrate. If both are selected for use, try switching priorities, and what do you see in MESSAGES? Is the GPS/Compass getting power? Sometimes it can be the connector at the fc I2C port or the GPS is loose. It could be a bad compass. Do you have another fc you can try with that compass?

closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.