Cannot connect via mavproxy, - MAV> link 1 down



i cannot connect via mavproxy on my raspberry pi. The raspberry pi is connected through a usb port on apm 2.5. I have tried the ideas from other thread but still shows same result. Please help!




It is difficult to help w/o knowing what specifically has been tried. Perhaps more info on the hardware used, exact wiring, software versions, and mavproxy output would be a start?


Hi Jax200

sry for the late reply!

I notice under the boot/config.txt that uart is enabled but i am using an USB, so i changed it but got same result as when the uart was enabled.

the firmware version for the apm2.5 is V.3.2.1
i downgraded the Mavproxy to 1.8.18
MAvproxy 2.4.15
python version that caleb recomends
Forgot to mention, i am using RPi 4

Thanks beforehand @jax200 @caleberg


The screenshots are a little hard to read, but it shows it’s connecting, so not sure what the problem is?

Also, I would seriously suggest ditching this old fc for at least one of the inexpensive Pixhawk 1 models used in the dojo build course.


Hii @jax200

sry for the missleading screenshoots, the black screen on the left is from the course, while the small black screen from the right is from my pi 4. So, No it is not connecting. I will uppload better photos

Yes, i am thinking about it but i want to make this work


Yes, it is more readable now. It seems you are doing things ok, although I have not tried using the USB.

I am not certain it would matter, but try lower case, so “enable_usb=1”.

Also the Interfacing options are changes in the RPi, see

I assume you have looked around, eg,

Hopefully someone who has had luck with this method will respond.



Yes hopefully!



@jax200 10 points

closed #9