Cannot connect to github for terminal use


Trying to use the git submodule update --init --recursive command for the “Ardupilot Installation Part 1” video but each time I run the command I get the following error

Do I need to login to github?


Look at the steps I provided in the previous message regarding WSL2 and see if it helps.


Thanks for the response!
I noticed in the line 36 we change directory into drone -> apm however, my apm is directly found from my cd ~ is that fine? Also I can find the Tools directory within apm/ardupilot/ArduCopter . when I try to ls I can’t find a Tools directory? Do you know what the issue could be?


It might be ok, but note that /dk and, in other courses, other folders will be at the same level as /apm, so it is better to collect drone related folders under a ‘courseRoot’ or other folder, eg, ‘drone’. Otherwise it can get messy. Your /.bashrc path statements might also get messed up.

The two dots in the …/Tools/autotest/ statement means ‘go up one level’. So ‘Tools’ is up one level. Were you able to initiate sim_vehicle?.

Apparently, I have found the SITL can be run with just ‘’ under ArduCopter -


I see, I dont think I was able to initiate sim_vehicle, I had the following error


Also how would I move all the contents within the apm directory to the drone directory?


I would do it over from flashing the RPi again and install per Caleb or the steps I provided.


Hey jax, how would I flash the RPi?


Should be in the course. Use Raspberry Pi Imager.


Hey jax, I tried redoing the steps and I noticed some weird error when I source ~/.bashrc

Im not to sure how to go about fixing this since I did not edit anything to do with that file


You started with fresh image? Don’t know how you could get this following the course video. Don’t know what syntax error this refers to. All I can offer is to list all of your steps here or send to my email.