2 ESCs beep 2 don't - [solved]-ish


Hi folks,
I did the ArduPilot ESC calibration and the one initiating calibration with the throttle up and power cycling.

So far 2 of the ESCs do the really nice beeping thing when attached to power without a control signal. But the other 2 ESCs don’t beep.

Also, the two that don’t beep seem to fidget a little and don’t spin up nearly as smooth or as fast as the other two that seem to be working fine. The two that are fidgety don’t move during the motor test at lower percentages of power but the “good ones” do.

I have what I understand to be the “newer” black SIMONK30A type.

I don’t think its a “motor screw too tight” issue because I swapped one of the motors from a “bad” arm to a good one and it ran smooth.

I would guess that the ESCs / motors should all beep about the same when no control signal is applied.

Also the “bad ones” seem to have either a different “tone” to them when “sounding off” after ESCs calibration. I could not tell if it was a higher or lower pitch, but I get two that sound one way and two that sound another way.

I also cleaned the motor connector with a q-tip and some alcohol.

Thanks a bunch.

Oh, and I upgraded the firmware.


Look at this previous forum Q&A (bottom) and see if it applies to you. Just cleaning with alcohol might not be enough.



I super did read through those posts. I tried an xacto knife to try and clean / get a good surface. The connection seems solid and I get a very definite difference if I unplug any of the wires.

Would a short video help explain what I’m seeing? It looks like I don’t yet have permissions to upload anything.

I should note if I swap thr motors whichever one is on the bad arm is bad.


OK You got me. Why are you using ‘fmuv3’ as your download source? For that board I use:


I think I got the idea to load FMUV3 from the documentation that came with th pixhawk.

I can connect to the pixhawk when I hit connect - but disconnecting and trying to load the pixhawk firmware always hangs when it is connecting.


Here is a really boring video of the firmware not loading.


I solved the not being able to upload firmware by deleting the comport in Device Manager. I think that helped ArduPilot evaluate its life choices and do a better job of looking for the pixhawk.

I was able to get the pixhawk into esc calibration / motor test.

I tested the motors with ArduPilot in motor test mode.

I first started with a motor on a bad arm jumpers over to a working arms esc. Then I put it back on its own to show the difference.

I hope the video makes sense. There is a funny bit where I test the motor that’s not connected…

But I think I got good footage of what I’m seeing. If anyone has further advice I’d be so happy to hear it.


@jax200 or @caleberg, would either of you have a moment to check out the last video I posted?


I must be missing something. They all seem ok now. Motor 2 seemed a little fidgety, but with more throttle it should be ok. You might try arming it and throttling it up slightly without props, upside down props or weighted down to ensure it is safe. Motor 4 spin direction needs to be fixed.


The motor direction isn’t a worry, that probably just got swapped when I was messing around.

So, in the video the first motor that spins up is on a borrowed ESC and then I switch it over to the one that seems bad to me, and it seems to not be running as well.

I think the two that are running poorly do ok with more throttle but don’t seem to be working well enough and the drone always flips over on take off.

I went through the whole “why is my drone flipping” article and the only thing I could come up with was that those two ESCs seem like they aren’t running the motors well.

But the differences by swapping the ESCs in the first part of the video seemed fine to you?

I could try again and see if it flips…

@jax200, thanks for the response, also I made sure everything was spining the right way and was calibrated when it was flipping.


Re-check all your wiring. Run through another full calibration procedure. Try re-calibrating the ESCs with MP instead. Then try throttling up a bit per the above so it doesn’t fly. If that doesn’t work then I guess I’d start looking to replace a bad ESC.


I did all of the above and was able to do two or three very amateur quality flight. I was very happy about that.

I triple checked the wiring to make sure the PWM wires were all going thr right places, motor directions, props, ESC calibrations, accelerometer calibration, rf calibration and motor tests - with the same results - and with flipping over.

I took it apart enough to get alternate ESCs in and it took off flying.

Individually the ESCs could be useful but the two that seemed bad, maybe they just weren’t firing correctly enough to generate the same power as the other two and just kept getting swamped out by the smoother ones faster than the autopilot could compensate.

This seems like territory where having alternate parts for A / B testing could be handy?

Thanks for all the help @jax200!!!


In this hobby you will accumulate lots of spare parts over time.
So you are good now? Congratulations!


I’ve achieved flight, which feels like a significant milestone.

My next goals are:

  1. More controlled flight
  2. More telemetry during flight / communicate with ground station
  3. Post flight data stuff


If you haven’t done so already, you should ensure failsafe has been set.
Then become familiar with the tuning process.
Download and review the flight logs.
Read my blog on drone safety.


Today over lunch I had time for a quick flight. I used “little g”, the roof of my neighbor’s van and some paver stones as my fail safe, after I lost a prop that shot off and sent my GPS module onto my neighbors roof.

Mrs. Bowes was kind enough to let me wiggle out the master bedroom window to retrieve the GPS from the gutter.

We both had a good laugh about my life choices and her dogs were unsure about my coming back through the upstairs window.

The excitement of building the rig and getting it in the air had it’s place but it’s time to “tighten up”, read and calibrate. I just didn’t feel like I was in thr game until I got a flight in.