MAVProxy crashes Python - version incompatibilities?


#1

I’m a new DroneKit user and am trying to run the simple_goto.py example script with SITL and MAVProxy. I “pip installed” dronekit, dronekit-sitl, and MAVProxy in a clean virtual environment. The versions I’m running are dronekit==2.9.2, dronekit-sitl==3.3.0, and MAVProxy==1.8.20. Per this issue I’m using pymavlink==2.4.8 instead of the newer version that cam with the other packages.

To run the example I run these commands in separate terminals, in order, as tutorial videos say to:

dronekit-sitl copter
mavproxy.py --master tcp:127.0.0.1:5760 --sitl 127.0.0.1:5501 --out 127.0.0.1:14550 --out 127.0.0.1:14551
python simple_goto.py --connect 127.0.0.1:14550

For the most part this appears to work and gets through the entire simple_goto example as expected. However, when I add the --map flag to the mavproxy command to load the map to see the mission, Python crashes. I’m using a Mac running OS-Catalina and using Python 3.8.4 (framework build). Has anyone had similar problems or have any suggestions? I really need to somehow get a working setup here, whatever it takes. What versions of dronekit/dronekit-sitl/mavproxy/python are working for you? Can you help me set up a working environment?

I also tried by getting the packages from their respective Git repos directly instead of “pip install”-ing them. Same problem.


#2

I reproduced your commands including --map without issue.

Installed in Virtualbox Windows 10 host.
Mavproxy 1.6.2
Dronekit-sitl 3.2.0
Dronekit 2.9.2
Copter 3.3

If you need this “whatever it takes”, did you use Caleb’s “dk-prewriten” config?